Learn business growth with Google Analytics 4 Forums Google Analytics 4 Some properties are missing BigQuery events tables

  • Some properties are missing BigQuery events tables

    Posted by Ethan on 8 April 2023 at 11:17 pm

    Hey, I’m trying to navigate some issues with GA4 Properties and BigQuery. I’ve got over 30 GA4 properties, all set up with data streams and connected to BigQuery. I’ve even taken the time to create all the datasets in BigQuery. However, for some peculiar reason, I’m only seeing the ‘events_YYYYMMDD’ table for 4 properties.

    Even after acknowledging there might be a delay, it’s been a good few weeks without any changes. Funny enough, I’ve gone through the same setup process for each of the feeds, but it seems like there’s some blockage.

    By the way, I’m currently using the BigQuery sandbox, but none of our data is close to hitting those limitations mentioned with this service. Do you have any ideas on troubleshooting steps that could help me out with this puzzle?

    I should mention I tried deleting and recreating data streams and links for the troublesome properties, but no luck so far. Any advice?

    Isabella replied 11 months, 2 weeks ago 3 Members · 2 Replies
  • 2 Replies
  • Charlotte

    Member
    28 June 2023 at 11:35 am

    Since you’ve already tried recreating your data streams, the issues you’re encountering may be due to some other factors. One possibility might be related to permissions: ensure that each property is properly linked to BigQuery and that the BigQuery service account has permission to access and write data.

    Another potential culprit might be how your datasets are organized in BigQuery. Google Analytics 4 (GA4) exports raw event data to BigQuery once a day under the dataset name that you’ve specified. If these datasets are not set up correctly or are inconsistent in some way, it may be causing complications.

    Sometimes, data can be delayed for a few hours even under ideal conditions, but as you’ve waited a few weeks already, it seems unlikely to be a simple delay issue. You may want to reach out to GA4 or BigQuery’s support services or consult an expert in these areas.

  • Isabella

    Member
    30 June 2023 at 4:45 pm

    It sounds like you’re experiencing quite the predicament with your GA4 Properties and BigQuery. My suggestion would be to look over your configurations again and ensure that these properties are all in the correct timezone. I would also suggest verifying your data stream and BigQuery link setups, as they might be hindering your properties. If this still doesn’t work, it might be worth seeking Google’s support directly, give them clear details about your issue and they should be able to help.

Log in to reply.